The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of jackson-databind: code execution via Axis2-transport-jms Deserialization

Synthesis of the vulnerability 

An attacker can use a vulnerability via Axis2-transport-jms Deserialization of jackson-databind, in order to run code.
Impacted software: Debian, Fedora, Oracle Communications, Oracle DB, Oracle Fusion Middleware, Tuxedo, WebLogic, Puppet, RHEL, SAS Add-in for Microsoft Office, SAS Analytics Pro, Base SAS Software, SAS BI Server, SAS Enterprise Guide, SAS Grid Computing, SAS Management Console, SAS OLAP Server, SAS SAS/ACCESS, SAS SAS/AF, SAS SAS/CONNECT, SAS SAS/EIS, SAS SAS/ETS, SAS SAS/FSP, SAS SAS/GRAPH, SAS SAS/IML, SAS SAS/INSIGHT, SAS SAS/OR, SAS SAS/STAT, SAS SAS/Web Report Studio.
Severity of this computer vulnerability: 3/4.
Creation date: 19/02/2019.
Références of this announce: 5048, cpuapr2019, cpujul2019, cpuoct2019, CVE-2018-19360, DLA-1703-1, DSA-4452-1, FEDORA-2019-df57551f6d, RHSA-2019:0782-01, VIGILANCE-VUL-28546.

Description of the vulnerability 

An attacker can use a vulnerability via Axis2-transport-jms Deserialization of jackson-databind, in order to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer vulnerability announce impacts software or systems such as Debian, Fedora, Oracle Communications, Oracle DB, Oracle Fusion Middleware, Tuxedo, WebLogic, Puppet, RHEL, SAS Add-in for Microsoft Office, SAS Analytics Pro, Base SAS Software, SAS BI Server, SAS Enterprise Guide, SAS Grid Computing, SAS Management Console, SAS OLAP Server, SAS SAS/ACCESS, SAS SAS/AF, SAS SAS/CONNECT, SAS SAS/EIS, SAS SAS/ETS, SAS SAS/FSP, SAS SAS/GRAPH, SAS SAS/IML, SAS SAS/INSIGHT, SAS SAS/OR, SAS SAS/STAT, SAS SAS/Web Report Studio.

Our Vigil@nce team determined that the severity of this cybersecurity bulletin is important.

The trust level is of type confirmed by the editor, with an origin of document.

An attacker with a expert ability can exploit this threat alert.

Solutions for this threat 

Continuous Delivery for Puppet Enterprise: version 2.18.2.
The version 2.18.2 is fixed:
  https://puppet.com/

Debian 8: new jackson-databind packages.
New packages are available:
  Debian 8: jackson-databind 2.4.2-2+deb8u5

Debian 9: new jackson-databind packages.
New packages are available:
  Debian 9: jackson-databind 2.8.6-1+deb9u5

Fedora 29: new bouncycastle packages.
New packages are available:
  Fedora 29: bouncycastle 1.61-1.fc29

Fedora 29: new eclipse-jgit packages.
New packages are available:
  Fedora 29: eclipse-jgit 5.2.0-4.fc29

Fedora 29: new eclipse-linuxtools packages.
New packages are available:
  Fedora 29: eclipse-linuxtools 7.1.0-3.fc29

Fedora 29: new jackson-annotations packages.
New packages are available:
  Fedora 29: jackson-annotations 2.9.8-1.fc29

Fedora 29: new jackson-bom packages.
New packages are available:
  Fedora 29: jackson-bom 2.9.8-1.fc29

Fedora 29: new jackson-core packages.
New packages are available:
  Fedora 29: jackson-core 2.9.8-1.fc29

Fedora 29: new jackson-databind packages.
New packages are available:
  Fedora 29: jackson-databind 2.9.8-1.fc29

Fedora 29: new jackson-dataformats-binary packages.
New packages are available:
  Fedora 29: jackson-dataformats-binary 2.9.8-1.fc29

Fedora 29: new jackson-dataformats-text packages.
New packages are available:
  Fedora 29: jackson-dataformats-text 2.9.8-1.fc29

Fedora 29: new jackson-dataformat-xml packages.
New packages are available:
  Fedora 29: jackson-dataformat-xml 2.9.8-1.fc29

Fedora 29: new jackson-datatype-jdk8 packages.
New packages are available:
  Fedora 29: jackson-datatype-jdk8 2.9.8-1.fc29

Fedora 29: new jackson-datatype-joda packages.
New packages are available:
  Fedora 29: jackson-datatype-joda 2.9.8-1.fc29

Fedora 29: new jackson-datatypes-collections packages.
New packages are available:
  Fedora 29: jackson-datatypes-collections 2.9.8-1.fc29

Fedora 29: new jackson-jaxrs-providers packages.
New packages are available:
  Fedora 29: jackson-jaxrs-providers 2.9.8-1.fc29

Fedora 29: new jackson-module-jsonSchema packages.
New packages are available:
  Fedora 29: jackson-module-jsonSchema 2.9.8-1.fc29

Fedora 29: new jackson-modules-base packages.
New packages are available:
  Fedora 29: jackson-modules-base 2.9.8-1.fc29

Fedora 29: new jackson-parent packages.
New packages are available:
  Fedora 29: jackson-parent 2.9.1.2-1.fc29

Oracle Communications: CPU of July 2019.
A Critical Patch Update is available:
  https://support.oracle.com/rs?type=doc&id=2559239.1
  https://support.oracle.com/rs?type=doc&id=2563691.1
  https://support.oracle.com/rs?type=doc&id=2559240.1
  https://support.oracle.com/rs?type=doc&id=2559722.1
  https://support.oracle.com/rs?type=doc&id=2559225.1
  https://support.oracle.com/rs?type=doc&id=2559721.1
  https://support.oracle.com/rs?type=doc&id=2559256.1
  https://support.oracle.com/rs?type=doc&id=2559242.1
  https://support.oracle.com/rs?type=doc&id=2559243.1
  https://support.oracle.com/rs?type=doc&id=2559648.1

Oracle Database: CPU of October 2019.
A Critical Patch Update is available:
  https://support.oracle.com/rs?type=doc&id=2568292.1

Oracle Fusion Middleware: CPU of April 2019.
A Critical Patch Update is available:
  https://support.oracle.com/rs?type=doc&id=2498664.1

RHEL 7: new rh-maven35-jackson-databind packages.
New packages are available:
  RHEL 7: rh-maven35-jackson-databind 2.7.6-2.5.el7

Rundeck: version 3.0.24.
The version 3.0.24 is fixed:
  https://docs.rundeck.com/downloads.html

SAS: version 9.4M6 TS1M6 11-19-2019.
The version 9.4M6 TS1M6 11-19-2019 is fixed:
  http://ftp.sas.com/techsup/download/hotfix/HF2/SAS_Security_Updates.html
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides software vulnerabilities analysis. The Vigil@nce vulnerability database contains several thousand vulnerabilities.