The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of libevent: three vulnerabilities

Synthesis of the vulnerability 

An attacker can use several vulnerabilities of libevent.
Vulnerable products: Debian, VNX Operating Environment, VNX Series, Fedora, Firefox, Thunderbird, openSUSE Leap, Oracle Fusion Middleware, Oracle Identity Management, Oracle OIT, Solaris, Tuxedo, WebLogic, pfSense, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this weakness: 2/4.
Number of vulnerabilities in this bulletin: 6.
Creation date: 15/02/2017.
Références of this bulletin: bulletinjul2018, CERTFR-2017-AVI-134, cpujul2017, CVE-2016-10195, CVE-2016-10196, CVE-2016-10197, CVE-2017-10195-ERROR, CVE-2017-10196-ERROR, CVE-2017-10197-ERROR, DLA-824-1, DSA-2020-030, DSA-2020-289, DSA-3789-1, FEDORA-2017-31c64a0bbf, FEDORA-2017-82265ed89e, FEDORA-2017-87e23bcc34, MFSA-2017-10, MFSA-2017-11, MFSA-2017-12, MFSA-2017-13, openSUSE-SU-2018:0220-1, RHSA-2017:1201-01, SSA:2017-112-01, SUSE-SU-2017:1669-1, SUSE-SU-2017:2235-1, USN-3228-1, USN-3278-1, VIGILANCE-VUL-21846.

Description of the vulnerability 

An attacker can use several vulnerabilities of libevent.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This cybersecurity threat impacts software or systems such as Debian, VNX Operating Environment, VNX Series, Fedora, Firefox, Thunderbird, openSUSE Leap, Oracle Fusion Middleware, Oracle Identity Management, Oracle OIT, Solaris, Tuxedo, WebLogic, pfSense, RHEL, Slackware, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer threat note is medium.

The trust level is of type confirmed by the editor, with an origin of document.

This bulletin is about 6 vulnerabilities.

An attacker with a expert ability can exploit this security threat.

Solutions for this threat 

Debian: new libevent packages.
New packages are available:
  Debian 7: libevent 2.0.19-stable-3+deb7u2
  Debian 8: libevent 2.0.21-stable-2+deb8u1

Dell EMC VNXe3200: version 3.1.11.10003441.
The version 3.1.11.10003441 is fixed:
  https://www.dell.com/support/

Fedora 25: new thunderbird packages.
New packages are available:
  Fedora 25: thunderbird 52.1.0-1.fc25

Fedora: new firefox packages.
New packages are available:
  Fedora 24: firefox 53.0-2.fc24
  Fedora 25: firefox 53.0-2.fc25

Firefox: version 45.9.
The version 45.9 is fixed:
  https://www.mozilla.org/en-US/firefox/new/

Firefox: version 52.1.
The version 52.1 is fixed:
  https://www.mozilla.org/en-US/firefox/new/

Firefox: version 53.
The version 53 is fixed:
  https://www.mozilla.org/en-US/firefox/new/

Mozilla Thunderbird: version 52.1.
The version 52.1 is fixed:
  https://www.mozilla.org/en-US/thunderbird/all/

openSUSE Leap: new libevent packages.
New packages are available:
  openSUSE Leap 42.3: libevent 2_0-5-2.0.21-10.1
  openSUSE Leap 42.2: libevent 2_0-5-2.0.21-7.3.1

Oracle Fusion Middleware: CPU of July 2017.
A Critical Patch Update is available:
  https://support.oracle.com/rs?type=doc&id=2261562.1

Oracle Solaris: patch for third party software of July 2018 v3.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

pfSense: version 2.3.4.
The version 2.3.4 is fixed:
  https://www.pfsense.org/

RHEL: new thunderbird packages.
New packages are available:
  RHEL 6: thunderbird 52.1.0-1.el6_9
  RHEL 7: thunderbird 52.1.0-1.el7_3

Slackware: new mozilla-firefox 45.9 packages.
New packages are available:
  Slackware 14.1: mozilla-firefox 45.9.0esr-*-1_slack14.1

SUSE LE 11: new MozillaFirefox packages (23/08/2017).
New packages are available:
  SUSE LE 11 SP3: MozillaFirefox 52.2.0esr-72.5.2, mozilla-nss 3.29.5-47.3.2
  SUSE LE 11 SP4: MozillaFirefox 52.2.0esr-72.5.2, mozilla-nss 3.29.5-47.3.2

SUSE LE 12: new MozillaFirefox packages (26/06/2017).
New packages are available:
  SUSE LE 12 RTM: MozillaFirefox 52.2.0esr-108.3
  SUSE LE 12 SP1: MozillaFirefox 52.2.0esr-108.3
  SUSE LE 12 SP2: MozillaFirefox 52.2.0esr-108.3

Ubuntu: new libevent-2.0-5 packages.
New packages are available:
  Ubuntu 16.10: libevent-2.0-5 2.0.21-stable-2ubuntu0.16.10.1
  Ubuntu 16.04 LTS: libevent-2.0-5 2.0.21-stable-2ubuntu0.16.04.1
  Ubuntu 14.04 LTS: libevent-2.0-5 2.0.21-stable-1ubuntu1.14.04.2
  Ubuntu 12.04 LTS: libevent-2.0-5 2.0.16-stable-1ubuntu0.2

Ubuntu: new thunderbird packages.
New packages are available:
  Ubuntu 17.04: thunderbird 1:52.1.1+build1-0ubuntu0.17.04.1
  Ubuntu 16.10: thunderbird 1:52.1.1+build1-0ubuntu0.16.10.1
  Ubuntu 16.04 LTS: thunderbird 1:52.1.1+build1-0ubuntu0.16.04.1
  Ubuntu 14.04 LTS: thunderbird 1:52.1.1+build1-0ubuntu0.14.04.1

VNXe1600: fixed versions for Third-Party Component.
Fixed versions are indicated in information sources.
This bulletin fixes more than 100 vulnerabilities, but only the 100 recent vulnerabilities were associated to this bulletin.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides system vulnerability bulletins. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.