The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of libgd: out-of-bounds memory reading via gdImageCreateFromTiffPtr

Synthesis of the vulnerability 

An attacker can force a read at an invalid address via gdImageCreateFromTiffPtr of libgd, in order to trigger a denial of service, or to obtain sensitive information.
Impacted software: Debian, Fedora, openSUSE, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this computer vulnerability: 1/4.
Creation date: 19/10/2016.
Références of this announce: CVE-2016-6911, DLA-665-1, FEDORA-2016-722c0afc64, FEDORA-2016-e45a7e7b13, openSUSE-SU-2016:2606-1, openSUSE-SU-2016:2772-1, openSUSE-SU-2016:2831-1, openSUSE-SU-2016:2837-1, SUSE-SU-2016:2460-2, SUSE-SU-2016:2668-1, SUSE-SU-2016:2683-1, SUSE-SU-2016:2683-2, SUSE-SU-2016:2766-1, USN-3117-1, VIGILANCE-VUL-20914.

Description of the vulnerability 

An attacker can force a read at an invalid address via gdImageCreateFromTiffPtr of libgd, in order to trigger a denial of service, or to obtain sensitive information.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer weakness impacts software or systems such as Debian, Fedora, openSUSE, openSUSE Leap, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this vulnerability note is low.

The trust level is of type confirmed by the editor, with an origin of document.

An attacker with a expert ability can exploit this cybersecurity threat.

Solutions for this threat 

Debian 7: new libgd2 packages.
New packages are available:
  Debian 7: libgd2 2.0.36~rc1~dfsg-6.1+deb7u6

Fedora: new gd packages.
New packages are available:
  Fedora 25: gd 2.2.3-5.fc25
  Fedora 24: gd 2.2.3-5.fc24

openSUSE 13.2: new php5 packages.
New packages are available:
  openSUSE 13.2: apache2-mod_php5 5.6.1-83.1, php5 5.6.1-83.1

openSUSE Leap 42.1: new gd packages.
New packages are available:
  openSUSE Leap 42.1: gd 2.1.0-13.1

openSUSE Leap: new php5 packages.
New packages are available:
  openSUSE Leap 42.1: apache2-mod_php5 5.5.14-65.2, php5 5.5.14-65.2
  openSUSE Leap 42.2: apache2-mod_php5 5.5.14-65.1, php5 5.5.14-65.1

SUSE LE 12: new gd packages.
New packages are available:
  SUSE LE 12 SP1: gd 2.1.0-17.1

SUSE LE 12: new php5 packages.
New packages are available:
  SUSE LE 12 RTM-SP2: apache2-mod_php5 5.5.14-83.1, php5 5.5.14-83.1

SUSE LE 12 SP2: new php7 packages.
New packages are available:
  SUSE LE 12 SP2: apache2-mod_php7 7.0.7-20.1, php7 7.0.7-20.1

Ubuntu: new libgd3 packages.
New packages are available:
  Ubuntu 16.10: libgd3 2.2.1-1ubuntu3.2
  Ubuntu 16.04 LTS: libgd3 2.1.1-4ubuntu0.16.04.5
  Ubuntu 14.04 LTS: libgd3 2.1.0-3ubuntu0.5
  Ubuntu 12.04 LTS: libgd2 2.0.36~rc1~dfsg-6ubuntu2.3
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides an applications vulnerabilities announce. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.