The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of libseccomp-golang: privilege escalation via Single Matching Argument

Synthesis of the vulnerability 

An attacker can bypass restrictions via Single Matching Argument of libseccomp-golang, in order to escalate his privileges.
Vulnerable software: Debian, Docker CE, Ubuntu.
Severity of this announce: 1/4.
Creation date: 09/10/2019.
Références of this computer vulnerability: CVE-2017-18367, DLA-2320-1, USN-4574-1, VIGILANCE-VUL-30565.

Description of the vulnerability 

An attacker can bypass restrictions via Single Matching Argument of libseccomp-golang, in order to escalate his privileges.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This threat impacts software or systems such as Debian, Docker CE, Ubuntu.

Our Vigil@nce team determined that the severity of this computer threat is low.

The trust level is of type confirmed by the editor, with an origin of user shell.

An attacker with a expert ability can exploit this cybersecurity bulletin.

Solutions for this threat 

Debian 9: new golang-github-seccomp-libseccomp-golang packages.
New packages are available:
  Debian 9: golang-github-seccomp-libseccomp-golang 0.0~git20150813.0.1b506fc-2+deb9u1

Docker Engine: version 19.03.3.
The version 19.03.3 is fixed:
  https://www.docker.com/

Ubuntu 16.04: new libseccomp-golang packages.
New packages are available:
  Ubuntu 16.04 LTS: golang-github-seccomp-libseccomp-golang-dev 0.0~git20150813.0.1b506fc-2+deb9u1build0.16.04.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a network vulnerability note. The Vigil@nce vulnerability database contains several thousand vulnerabilities.