The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of libslirp: buffer overflow via ip_reass

Synthesis of the vulnerability 

An attacker can trigger a buffer overflow via ip_reass() of libslirp, in order to trigger a denial of service, and possibly to run code.
Impacted software: Debian, Fedora, openSUSE Leap, QEMU, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu, Unix (platform) ~ not comprehensive.
Severity of this computer vulnerability: 3/4.
Creation date: 01/08/2019.
Références of this announce: CVE-2019-14378, DLA-1927-1, DSA-4506-1, DSA-4512-1, FEDORA-2019-77bafc4454, openSUSE-SU-2019:2041-1, openSUSE-SU-2019:2059-1, openSUSE-SU-2019:2510-1, RHSA-2019:3403-01, RHSA-2019:3494-01, RHSA-2019:3968-01, RHSA-2020:0366-01, RHSA-2020:0775-01, RHSA-2020:0889-01, RHSA-2020:2065-01, RHSA-2020:2126-01, SUSE-SU-2019:14151-1, SUSE-SU-2019:2157-1, SUSE-SU-2019:2192-1, SUSE-SU-2019:2221-1, SUSE-SU-2019:2246-1, SUSE-SU-2019:2353-1, SUSE-SU-2019:2783-1, SUSE-SU-2019:2955-1, SUSE-SU-2020:0388-1, USN-4191-1, USN-4191-2, VIGILANCE-VUL-29926.

Description of the vulnerability 

An attacker can trigger a buffer overflow via ip_reass() of libslirp, in order to trigger a denial of service, and possibly to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This weakness note impacts software or systems such as Debian, Fedora, openSUSE Leap, QEMU, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu, Unix (platform) ~ not comprehensive.

Our Vigil@nce team determined that the severity of this threat note is important.

The trust level is of type confirmed by the editor, with an origin of internet client.

An attacker with a expert ability can exploit this computer weakness.

Solutions for this threat 

libslirp: patch for ip_reass.
A patch is indicated in information sources.

Debian 10: new qemu packages.
New packages are available:
  Debian 10: qemu 1:3.1+dfsg-8+deb10u2

Debian 8: new qemu packages (duplicate).
This bulletin is a duplicate of VIGILANCE-SOL-68382.

Debian 8: new qemu packages (original).
New packages are available:
  Debian 8: qemu 1:2.1+dfsg-12+deb8u12

Debian 9: new qemu packages.
New packages are available:
  Debian 9: qemu 1:2.8+dfsg-6+deb9u8

Fedora 30: new libslirp packages.
New packages are available:
  Fedora 30: libslirp 4.0.0-2.fc30

openSUSE Leap 15.0: new qemu packages.
New packages are available:
  openSUSE Leap 15.0: qemu 2.11.2-lp150.7.25.1

openSUSE Leap 15.1: new qemu packages (02/09/2019).
New packages are available:
  openSUSE Leap 15.1: qemu 3.1.1-lp151.7.3.3

openSUSE Leap 15.1: new qemu packages (14/11/2019).
New packages are available:
  openSUSE Leap 15.1: qemu 3.1.1.1-lp151.7.6.1

QEMU: patch for slirp.
A patch is indicated in information sources.

QEMU: version 4.0.1.
The version 4.0.1 is fixed:
  https://www.qemu.org/download/#source

RHEL 6.10: new qemu-kvm packages.
New packages are available:
  RHEL 6.10: qemu-kvm 0.12.1.2-2.506.el6_10.6

RHEL 7.6: new qemu-kvm packages.
New packages are available:
  RHEL 7.6: qemu-kvm 1.5.3-160.el7_6.6

RHEL 7.7: new qemu-kvm packages.
New packages are available:
  RHEL 7.7: qemu-kvm 1.5.3-167.el7_7.4

RHEL 7: new qemu-kvm-ma packages.
New packages are available:
  RHEL 7.7: qemu-kvm-ma 2.12.0-33.el7_7.1
  RHEL 7.6: qemu-kvm-ma 2.12.0-18.el7_6.6

RHEL 7: new slirp4netns packages.
New packages are available:
  RHEL 7.7: slirp4netns 0.3.0-8.el7_7

RHEL 8: new container-tools-1.0 module.
The following module is updated:
  RHEL 8 Module: container-tools:1.0

RHEL 8: new container-tools-rhel8 module.
The following module is updated:
  RHEL 8 Module: container-tools:rhel8

SUSE LE 11 SP4: new kvm packages.
New packages are available:
  SUSE LE 11 SP4: kvm 1.4.2-60.27.1

SUSE LE 12 SP1: new qemu packages.
New packages are available:
  SUSE LE 12 SP1: qemu 2.3.1-33.26.1

SUSE LE 12 SP1: new xen packages.
New packages are available:
  SUSE LE 12 SP1: xen 4.5.5_28-22.64.1

SUSE LE 12 SP2: new qemu packages.
New packages are available:
  SUSE LE 12 SP2: qemu 2.6.2-41.55.1

SUSE LE 12 SP2: new xen packages.
New packages are available:
  SUSE LE 12 SP2: xen 4.7.6_06-43.54.2

SUSE LE 12 SP4: new qemu packages.
New packages are available:
  SUSE LE 12 SP4: qemu 2.11.2-5.18.1

SUSE LE 15: new qemu packages.
New packages are available:
  SUSE LE 15 RTM: qemu 2.11.2-9.28.3

SUSE LE 15 SP1: new qemu packages (13/11/2019).
New packages are available:
  SUSE LE 15 SP1: qemu 3.1.1.1-9.6.2

SUSE LE 15 SP1: new qemu packages (22/08/2019).
New packages are available:
  SUSE LE 15 SP1: qemu 3.1.1-9.3.3

Ubuntu: new qemu packages.
New packages are available:
  Ubuntu 19.10: qemu 1:4.0+dfsg-0ubuntu9.1
  Ubuntu 19.04: qemu 1:3.1+dfsg-2ubuntu3.6
  Ubuntu 18.04 LTS: qemu 1:2.11+dfsg-1ubuntu7.20
  Ubuntu 16.04 LTS: qemu 1:2.5+dfsg-5ubuntu10.42
  Ubuntu 14.04 ESM: qemu 2.0.0+dfsg-2ubuntu1.47
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a computer security alert. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.