The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of libvirt: code execution via virDomainSaveImageGetXMLDesc

Synthesis of the vulnerability 

An attacker can use a vulnerability via virDomainSaveImageGetXMLDesc of libvirt, in order to run code.
Vulnerable products: Debian, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this weakness: 2/4.
Creation date: 21/06/2019.
Références of this bulletin: CVE-2019-10161, DLA-1832-1, DSA-4469-1, openSUSE-SU-2019:1672-1, openSUSE-SU-2019:1753-1, RHSA-2019:1578-01, RHSA-2019:1579-01, RHSA-2019:1580-01, SUSE-SU-2019:14097-1, SUSE-SU-2019:14100-1, SUSE-SU-2019:1599-1, SUSE-SU-2019:1637-1, SUSE-SU-2019:1643-1, SUSE-SU-2019:1686-1, SUSE-SU-2019:1690-1, SUSE-SU-2019:2105-1, SUSE-SU-2019:2227-1, SUSE-SU-2019:2227-2, USN-4047-1, USN-4047-2, VIGILANCE-VUL-29592.

Description of the vulnerability 

An attacker can use a vulnerability via virDomainSaveImageGetXMLDesc of libvirt, in order to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This threat bulletin impacts software or systems such as Debian, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer threat bulletin is medium.

The trust level is of type confirmed by the editor, with an origin of user account.

An attacker with a expert ability can exploit this computer threat.

Solutions for this threat 

Debian 8: new libvirt packages.
New packages are available:
  Debian 8: libvirt 1.2.9-9+deb8u7

Debian 9: new libvirt packages.
New packages are available:
  Debian 9: libvirt 3.0.0-4+deb9u4

openSUSE Leap 15.0: new libvirt packages.
New packages are available:
  openSUSE Leap 15.0: libvirt 4.0.0-lp150.7.18.2

openSUSE Leap 15.1: new libvirt packages.
New packages are available:
  openSUSE Leap 15.1: libvirt 5.1.0-lp151.7.3.1

RHEL 6.10: new libvirt packages.
New packages are available:
  RHEL 6: libvirt 0.10.2-64.el6_10.2

RHEL 7.6: new libvirt packages.
New packages are available:
  RHEL 7: libvirt 4.5.0-10.el7_6.12

RHEL 8: new virt-rhel module.
The following module is updated:
  RHEL 8 Module: virt:rhel

SUSE LE 11 SP3: new libvirt packages.
New packages are available:
  SUSE LE 11 SP3: libvirt 1.0.5.9-21.20.1

SUSE LE 11 SP4: new libvirt packages.
New packages are available:
  SUSE LE 11 SP4: libvirt 1.2.5-23.20.1

SUSE LE 12 RTM: new libvirt packages.
New packages are available:
  SUSE LE 12 RTM: libvirt 1.2.5-27.19.1

SUSE LE 12 SP1: new libvirt packages.
New packages are available:
  SUSE LE 12 SP1: libvirt 1.2.18.4-22.13.1

SUSE LE 12 SP2: new libvirt packages.
New packages are available:
  SUSE LE 12 SP2: libvirt 2.0.0-27.61.1

SUSE LE 12 SP3: new libvirt packages (12/09/2019).
New packages are available:
  SUSE LE 12 SP3: libvirt 3.3.0-5.40.1

SUSE LE 12 SP3: new libvirt packages (28/08/2019).
New packages are available:
  SUSE LE 12 SP3: libvirt 3.3.0-5.40.1

SUSE LE 12 SP4: new libvirt packages.
New packages are available:
  SUSE LE 12 SP4: libvirt 4.0.0-8.15.2

SUSE LE 15 RTM: new libvirt packages.
New packages are available:
  SUSE LE 15 RTM: libvirt 4.0.0-9.27.1

SUSE LE 15 SP1: new libvirt packages.
New packages are available:
  SUSE LE 15 SP1: libvirt 5.1.0-8.6.1

Ubuntu 14.04: new libvirt packages.
New packages are available:
  Ubuntu 14.04 ESM: libvirt 1.2.2-0ubuntu13.1.28+esm1

Ubuntu: new libvirt packages.
New packages are available:
  Ubuntu 19.04: libvirt 5.0.0-1ubuntu2.4
  Ubuntu 18.10: libvirt 4.6.0-2ubuntu3.8
  Ubuntu 18.04 LTS: libvirt 4.0.0-1ubuntu8.12
  Ubuntu 16.04 LTS: libvirt 1.3.1-1ubuntu10.27
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides network vulnerability analysis. The Vigil@nce computer vulnerability tracking service alerts your teams of vulnerabilities or threats impacting your information system.