The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of libvirt: wrong permissions of admin-sock

Synthesis of the vulnerability 

An attacker can make profit of wrongly defined permissions to admin-sock of libvirt, in order to increase his privileges.
Impacted systems: RHEL, SLES, Ubuntu.
Severity of this alert: 2/4.
Creation date: 24/05/2019.
Références of this alert: CVE-2019-10132, RHSA-2019:1264-01, RHSA-2019:1268-01, SUSE-SU-2019:1490-1, USN-4021-1, VIGILANCE-VUL-29399.

Description of the vulnerability 

An attacker can make profit of wrongly defined permissions to admin-sock of libvirt, in order to increase his privileges.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This security note impacts software or systems such as RHEL, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this threat announce is medium.

The trust level is of type confirmed by the editor, with an origin of user shell.

An attacker with a expert ability can exploit this computer weakness announce.

Solutions for this threat 

RHEL 7.6: new libvirt packages.
New packages are available:
  RHEL 7: libvirt 4.5.0-10.el7_6.10

RHEL 8: new virt-rhel modules.
New modules are available, as indicated in information sources.

SUSE LE 15 SP1: new libvirt packages.
New packages are available:
  SUSE LE 15 SP1: libvirt 5.1.0-8.3.1

Ubuntu: new libvirt packages.
New packages are available:
  Ubuntu 19.04: libvirt 5.0.0-1ubuntu2.3
  Ubuntu 18.10: libvirt 4.6.0-2ubuntu3.7
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides computers vulnerabilities patches. The Vigil@nce vulnerability database contains several thousand vulnerabilities.