The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of nginx: denial of service via ngx_http_v2_module

Synthesis of the vulnerability 

An attacker can generate a fatal error via ngx_http_v2_module of nginx, in order to trigger a denial of service.
Impacted products: Debian, IBM API Connect, nginx, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this bulletin: 3/4.
Number of vulnerabilities in this bulletin: 2.
Creation date: 06/11/2018.
Références of this threat: CERTFR-2018-AVI-535, CVE-2018-16843, CVE-2018-16844, DSA-4335-1, ibm10960610, openSUSE-SU-2019:0195-1, openSUSE-SU-2019:2120-1, RHSA-2018:3653-01, RHSA-2018:3680-01, RHSA-2018:3681-01, SUSE-SU-2019:0334-1, SUSE-SU-2019:2309-1, USN-3812-1, VIGILANCE-VUL-27705.

Description of the vulnerability 

An attacker can generate a fatal error via ngx_http_v2_module of nginx, in order to trigger a denial of service.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This threat impacts software or systems such as Debian, IBM API Connect, nginx, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this computer threat is important.

The trust level is of type confirmed by the editor, with an origin of internet client.

This bulletin is about 2 vulnerabilities.

An attacker with a expert ability can exploit this cybersecurity bulletin.

Solutions for this threat 

nginx: version 1.15.6.
The version 1.15.6 is fixed:
  https://nginx.org/en/download.html

nginx: version 1.14.1.
The version 1.14.1 is fixed:
  https://nginx.org/en/download.html

Debian 9: new nginx packages.
New packages are available:
  Debian 9: nginx 1.10.3-1+deb9u2

IBM API Connect: patch for nginx.
A patch is indicated in information sources.

openSUSE Leap 15.1: new nginx packages.
New packages are available:
  openSUSE Leap 15.1: nginx 1.14.2-lp151.4.3.1

openSUSE Leap: new nginx packages.
New packages are available:
  openSUSE Leap 42.3: nginx 1.14.2-2.7.1
  openSUSE Leap 15.0: nginx 1.14.2-lp150.2.4.1
  SUSE LE 12 RTM-SP4: nginx 1.14.2-16.1

RHEL 7: new rh-nginx112-nginx packages.
New packages are available:
  RHEL 7: rh-nginx112-nginx 1.12.1-2.el7.1

RHEL 7: new rh-nginx114-nginx packages.
New packages are available:
  RHEL 7: rh-nginx114-nginx 1.14.1-1.el7

RHEL: new rh-nginx110-nginx packages.
New packages are available:
  RHEL 6: rh-nginx110-nginx 1.10.2-8.el6.1
  RHEL 7: rh-nginx110-nginx 1.10.2-8.el7.1

SUSE LE 15: new nginx packages.
New packages are available:
  SUSE LE 15 RTM: nginx 1.14.2-3.3.1

SUSE LE 15 SP1: new nginx packages.
New packages are available:
  SUSE LE 15 SP1: nginx 1.14.2-6.3.1

Ubuntu: new nginx packages.
New packages are available:
  Ubuntu 18.10: nginx 1.15.5-0ubuntu2.1
  Ubuntu 18.04 LTS: nginx 1.14.0-0ubuntu1.2
  Ubuntu 16.04 LTS: nginx 1.10.3-0ubuntu0.16.04.3
  Ubuntu 14.04 LTS: nginx 1.4.6-1ubuntu3.9

Wind River Linux: solution (28/11/2018).
The solution is indicated in information sources.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a computers vulnerabilities database. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.