The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a database and tools to fix them.

vulnerability note 27934

pfSense: Cross Site Scripting via WebGUI

Synthesis of the vulnerability

An attacker can trigger a Cross Site Scripting via WebGUI of pfSense, in order to run JavaScript code in the context of the web site.
Impacted software: pfSense.
Severity of this computer vulnerability: 2/4.
Consequences of a hack: client access/rights.
Attacker's origin: document.
Creation date: 03/12/2018.
Références of this announce: pfSense-SA-18_06.webgui, VIGILANCE-VUL-27934.

Description of the vulnerability

The pfSense product offers a web service.

However, it does not filter received data via WebGUI before inserting them in generated HTML documents.

An attacker can therefore trigger a Cross Site Scripting via WebGUI of pfSense, in order to run JavaScript code in the context of the web site.
Full Vigil@nce bulletin... (Free trial)

Computer vulnerabilities tracking service

Vigil@nce provides an applications vulnerabilities management. The Vigil@nce vulnerability database contains several thousand vulnerabilities. The technology watch team tracks security threats targeting the computer system. The Vigil@nce team tracks computer vulnerabilities impacting systems and applications.