The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of ppp: buffer overflow via eap_request

Synthesis of the vulnerability 

An attacker can trigger a buffer overflow via eap_request() of ppp, in order to trigger a denial of service, and possibly to run code.
Vulnerable systems: GAiA, CheckPoint IP Appliance, CheckPoint Security Appliance, Debian, Android OS, openSUSE Leap, RHEL, ROS, RuggedSwitch, Slackware, SUSE Linux Enterprise Desktop, SLES, Synology DSM, Ubuntu.
Severity of this threat: 3/4.
Creation date: 10/02/2020.
Références of this weakness: CERTFR-2020-AVI-494, CVE-2020-8597, DLA-2097-1, DSA-4632-1, openSUSE-SU-2020:0286-1, RHSA-2020:0630-01, RHSA-2020:0631-01, RHSA-2020:0633-01, RHSA-2020:0634-01, sk165875, SSA:2020-064-01, SSA-809841, SUSE-SU-2020:0489-1, SUSE-SU-2020:14292-1, Synology-SA-20:02, USN-4288-1, USN-4288-2, VIGILANCE-VUL-31562, VU#782301.

Description of the vulnerability 

An attacker can trigger a buffer overflow via eap_request() of ppp, in order to trigger a denial of service, and possibly to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer weakness impacts software or systems such as GAiA, CheckPoint IP Appliance, CheckPoint Security Appliance, Debian, Android OS, openSUSE Leap, RHEL, ROS, RuggedSwitch, Slackware, SUSE Linux Enterprise Desktop, SLES, Synology DSM, Ubuntu.

Our Vigil@nce team determined that the severity of this vulnerability note is important.

The trust level is of type confirmed by the editor, with an origin of intranet client.

A proof of concept or an attack tool is available, so your teams have to process this alert. An attacker with a technician ability can exploit this cybersecurity threat.

Solutions for this threat 

Check Point Gaia: version Jumbo Hotfix for R80.40 Take 25.
The version Jumbo Hotfix for R80.40 Take 25 is fixed:
  https://supportcenter.us.checkpoint.com/supportcenter/portal?eventSubmit_doGoviewsolutiondetails=&solutionid=sk165456

Debian 8: new ppp packages.
New packages are available:
  Debian 8: ppp 2.4.6-3.1+deb8u1

Debian 9/10: new ppp packages.
New packages are available:
  Debian 9: ppp 2.4.7-1+4+deb9u1
  Debian 10: ppp 2.4.7-2+4.1+deb10u1

Google Android/Pixel: patch for June 2020.
A patch is indicated in information sources.

openSUSE Leap 15.1: new ppp packages.
New packages are available:
  openSUSE Leap 15.1: ppp 2.4.7-lp151.5.3.1

RHEL 6.10: new ppp packages.
New packages are available:
  RHEL 6.10: ppp 2.4.5-11.el6_10

RHEL 7.7: new ppp packages.
New packages are available:
  RHEL 7.7: ppp 2.4.5-34.el7_7

RHEL 8.0: new ppp packages.
New packages are available:
  RHEL 8.0: ppp 2.4.7-26.el8_0

RHEL 8.1: new ppp packages.
New packages are available:
  RHEL 8.1: ppp 2.4.7-26.el8_1

RUGGEDCOM RM1224: version 6.3.
The version 6.3 is fixed:
  https://support.industry.siemens.com/cs/ww/en/view/109781070

Slackware: new ppp packages.
New packages are available:
  Slackware 14.0: ppp 2.4.8-*-1_slack14.0
  Slackware 14.1: ppp 2.4.8-*-1_slack14.1
  Slackware 14.2: ppp 2.4.8-*-1_slack14.2

SUSE LE 11 SP3/4: new ppp packages.
New packages are available:
  SUSE LE 11 SP3: ppp 2.4.5.git-2.32.3.1
  SUSE LE 11 SP4: ppp 2.4.5.git-2.32.3.1

SUSE LE 15: new ppp packages.
New packages are available:
  SUSE LE 15 RTM: ppp 2.4.7-5.3.1
  SUSE LE 15 SP1: ppp 2.4.7-5.3.1

Synology DSM: fixed versions for ppp.
Fixed versions are indicated in information sources.

Ubuntu: new ppp packages.
New packages are available:
  Ubuntu 19.10: ppp 2.4.7-2+4.1ubuntu4.1
  Ubuntu 18.04 LTS: ppp 2.4.7-2+2ubuntu1.2
  Ubuntu 16.04 LTS: ppp 2.4.7-1+2ubuntu1.16.04.2
  Ubuntu 14.04 ESM: ppp 2.4.5-5.1ubuntu2.3+esm1
  Ubuntu 12.04 ESM: ppp 2.4.5-5ubuntu1.3

Wind River Linux: version 10.17.41.20.
The version 10.17.41.20 is fixed:
  https://support2.windriver.com/
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides computers vulnerabilities announces. The Vigil@nce vulnerability database contains several thousand vulnerabilities.