The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of strongSwan: memory corruption via stroke_socket.c

Synthesis of the vulnerability 

An attacker can generate a memory corruption via stroke_socket.c of strongSwan, in order to trigger a denial of service, and possibly to run code.
Vulnerable systems: Debian, Fedora, openSUSE Leap, pfSense, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this threat: 3/4.
Creation date: 28/05/2018.
Références of this weakness: CVE-2018-5388, DSA-4229-1, FEDORA-2018-3731a89e20, openSUSE-SU-2019:2594-1, openSUSE-SU-2019:2598-1, SUSE-SU-2019:3056-1, SUSE-SU-2019:3266-1, USN-3771-1, VIGILANCE-VUL-26240, VU#338343.

Description of the vulnerability 

An attacker can generate a memory corruption via stroke_socket.c of strongSwan, in order to trigger a denial of service, and possibly to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This weakness impacts software or systems such as Debian, Fedora, openSUSE Leap, pfSense, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this vulnerability announce is important.

The trust level is of type confirmed by the editor, with an origin of internet client.

An attacker with a expert ability can exploit this threat bulletin.

Solutions for this threat 

Debian: new strongswan packages.
New packages are available:
  Debian 8: strongswan 5.2.1-6+deb8u6
  Debian 9: strongswan 5.5.1-4+deb9u2

Fedora 28: new strongswan packages.
New packages are available:
  Fedora 28: strongswan 5.6.2-6.fc28

openSUSE Leap 15: new strongswan packages.
New packages are available:
  openSUSE Leap 15.0: strongswan 5.6.0-lp150.3.3.1
  openSUSE Leap 15.1: strongswan 5.6.0-lp151.4.3.1

pfSense: version 2.4.4.
The version 2.4.4 is fixed:
  https://www.netgate.com/

SUSE LE 12: new strongswan packages.
New packages are available:
  SUSE LE 12 SP1: strongswan 5.1.3-26.13.1
  SUSE LE 12 SP2: strongswan 5.1.3-26.13.1
  SUSE LE 12 SP3: strongswan 5.1.3-26.13.1
  SUSE LE 12 SP4: strongswan 5.1.3-26.13.1
  SUSE LE 12 SP5: strongswan 5.1.3-26.13.1

SUSE LE 15: new strongswan packages.
New packages are available:
  SUSE LE 15 SP1: strongswan 5.6.0-4.3.2

Ubuntu: new strongswan packages.
New packages are available:
  Ubuntu 18.04 LTS: strongswan 5.6.2-1ubuntu2.2
  Ubuntu 16.04 LTS: strongswan 5.3.5-1ubuntu3.7
  Ubuntu 14.04 LTS: strongswan 5.1.2-0ubuntu2.10
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a software vulnerabilities patch. The Vigil@nce security watch publishes vulnerability bulletins about threats impacting the information system.