The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of systemd: code execution via unit_deserialize

Synthesis of the vulnerability 

An attacker can use a vulnerability via unit_deserialize() of systemd, in order to run code.
Vulnerable systems: Debian, McAfee Web Gateway, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this threat: 2/4.
Creation date: 07/11/2018.
Références of this weakness: CVE-2018-15686, DLA-1580-1, openSUSE-SU-2018:3695-1, openSUSE-SU-2018:3803-1, RHSA-2019:2091-01, RHSA-2019:3222-01, RHSA-2020:0593-01, RHSA-2020:1264-01, SUSE-SU-2018:3644-1, SUSE-SU-2018:3767-1, SUSE-SU-2018:3767-2, SUSE-SU-2019:0053-1, SUSE-SU-2019:0054-1, SUSE-SU-2019:0054-2, USN-3816-1, USN-3816-2, USN-3816-3, VIGILANCE-VUL-27716.

Description of the vulnerability 

An attacker can use a vulnerability via unit_deserialize() of systemd, in order to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This cybersecurity weakness impacts software or systems such as Debian, McAfee Web Gateway, openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this security vulnerability is medium.

The trust level is of type confirmed by the editor, with an origin of user shell.

An attacker with a expert ability can exploit this vulnerability bulletin.

Solutions for this threat 

Debian 8: new systemd packages.
New packages are available:
  Debian 8: systemd 215-17+deb8u8

McAfee Web Gateway: version 8.2.2.
The version 8.2.2 is fixed:
  https://www.mcafee.com/enterprise/en-us/downloads/my-products.html

McAfee Web Gateway: version 9.0.
The version 9.0 is fixed:
  https://www.mcafee.com/enterprise/en-us/downloads/my-products.html

openSUSE Leap 15.0: new systemd packages.
New packages are available:
  openSUSE Leap 15.0: systemd 234-lp150.20.9.1

openSUSE Leap 42.3: new systemd packages.
New packages are available:
  openSUSE Leap 42.3: systemd 228-62.1

RHEL 7.4: new systemd packages.
New packages are available:
  RHEL 7.4: systemd 219-42.el7_4.20

RHEL 7.5: new systemd packages.
New packages are available:
  RHEL 7.5: systemd 219-57.el7_5.9

RHEL 7.6: new systemd packages.
New packages are available:
  RHEL 7: systemd 219-62.el7_6.11

RHEL 7: new systemd packages.
New packages are available:
  RHEL 7: systemd 219-67.el7

SUSE LE 12: new systemd packages.
New packages are available:
  SUSE LE 12 SP2: systemd 228-150.53.3
  SUSE LE 12 SP3: systemd 228-150.53.3

SUSE LE 12 RTM/SP1: new systemd packages.
New packages are available:
  SUSE LE 12 RTM: systemd 210-70.74.1
  SUSE LE 12 SP1: systemd 210-116.19.1

SUSE LE 12 SP4: new systemd packages.
New packages are available:
  SUSE LE 12 SP4: systemd 228-150.53.3

SUSE LE 15: new systemd packages.
New packages are available:
  SUSE LE 15 RTM: systemd 234-24.15.1

Ubuntu: new systemd packages.
New packages are available:
  Ubuntu 18.10: systemd 239-7ubuntu10.4
  Ubuntu 18.04 LTS: systemd 237-3ubuntu10.9
  Ubuntu 16.04 LTS: systemd 229-4ubuntu21.10

Wind River Linux: solution (28/11/2018).
The solution is indicated in information sources.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides an application vulnerability database. The Vigil@nce computer vulnerability tracking service alerts your teams of vulnerabilities or threats impacting your information system.