The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of systemd: use after free via Asynchronous Polkit Queries

Synthesis of the vulnerability 

An attacker can force the usage of a freed memory area via Asynchronous Polkit Queries of systemd, in order to trigger a denial of service, and possibly to run code.
Impacted products: openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.
Severity of this bulletin: 2/4.
Creation date: 06/02/2020.
Références of this threat: CVE-2020-1712, openSUSE-SU-2020:0208-1, PROJ-ZERO-1971, RHSA-2020:0564-01, RHSA-2020:0575-01, SUSE-SU-2020:0331-1, SUSE-SU-2020:0335-1, SUSE-SU-2020:0353-1, USN-4269-1, VIGILANCE-VUL-31527.

Description of the vulnerability 

An attacker can force the usage of a freed memory area via Asynchronous Polkit Queries of systemd, in order to trigger a denial of service, and possibly to run code.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This vulnerability impacts software or systems such as openSUSE Leap, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Our Vigil@nce team determined that the severity of this security announce is medium.

The trust level is of type confirmed by the editor, with an origin of user shell.

An attacker with a expert ability can exploit this computer vulnerability note.

Solutions for this threat 

openSUSE Leap 15.1: new systemd packages.
New packages are available:
  openSUSE Leap 15.1: systemd 234-lp151.26.7.1

RHEL 8.0: new systemd packages.
New packages are available:
  RHEL 8.0: systemd 239-13.el8_0.7

RHEL 8.1: new systemd packages.
New packages are available:
  RHEL 8.1: systemd 239-18.el8_1.4

SUSE LE 12: new systemd packages.
New packages are available:
  SUSE LE 12 SP2: systemd 228-150.82.1
  SUSE LE 12 SP3: systemd 228-150.82.1
  SUSE LE 12 SP4: systemd 228-150.82.1

SUSE LE 12 SP5: new systemd packages.
New packages are available:
  SUSE LE 12 SP5: systemd 228-157.9.1

SUSE LE 15: new systemd packages.
New packages are available:
  SUSE LE 15 RTM: systemd 234-24.39.1
  SUSE LE 15 SP1: systemd 234-24.39.1

Ubuntu: new systemd packages.
New packages are available:
  Ubuntu 19.10: systemd 242-7ubuntu3.6
  Ubuntu 18.04 LTS: systemd 237-3ubuntu10.38
  Ubuntu 16.04 LTS: systemd 229-4ubuntu21.27

Wind River Linux: version 10.17.41.21.
The version 10.17.41.21 is fixed:
  https://support2.windriver.com/

Wind River Linux: version 10.18.44.17.
The version 10.18.44.17 is fixed:
  https://support2.windriver.com/

Wind River Linux: version 10.19.45.7.
The version 10.19.45.7 is fixed:
  https://support2.windriver.com/
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a software vulnerabilities announce. The Vigil@nce computer vulnerability tracking service alerts your teams of vulnerabilities or threats impacting your information system.