The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of tcpdump: out-of-bounds memory reading via print_prefix

Synthesis of the vulnerability 

An attacker can force a read at an invalid address via print_prefix() of tcpdump, in order to trigger a denial of service, or to obtain sensitive information.
Impacted products: Fedora, AIX, McAfee Web Gateway, openSUSE Leap, Solaris, RHEL, SUSE Linux Enterprise Desktop, SLES, tcpdump, Ubuntu.
Severity of this bulletin: 2/4.
Number of vulnerabilities in this bulletin: 2.
Creation date: 17/12/2018.
Références of this threat: 763, bulletinjul2019, CVE-2018-19519, CVE-2019-1010220, FEDORA-2019-6db0d5b9d9, FEDORA-2019-85d92df70f, FEDORA-2019-d06bc63433, openSUSE-SU-2018:4144-1, openSUSE-SU-2018:4252-1, openSUSE-SU-2019:1964-1, openSUSE-SU-2019:2344-1, openSUSE-SU-2019:2348-1, RHSA-2019:3976-01, RHSA-2020:1604-01, SUSE-SU-2018:4131-1, SUSE-SU-2018:4149-1, SUSE-SU-2019:2087-1, SUSE-SU-2019:2088-1, SUSE-SU-2019:2674-1, USN-4252-1, USN-4252-2, VIGILANCE-VUL-28029.

Description of the vulnerability 

An attacker can force a read at an invalid address via print_prefix() of tcpdump, in order to trigger a denial of service, or to obtain sensitive information.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This computer vulnerability bulletin impacts software or systems such as Fedora, AIX, McAfee Web Gateway, openSUSE Leap, Solaris, RHEL, SUSE Linux Enterprise Desktop, SLES, tcpdump, Ubuntu.

Our Vigil@nce team determined that the severity of this vulnerability bulletin is medium.

The trust level is of type confirmed by the editor, with an origin of internet client.

This bulletin is about 2 vulnerabilities.

A proof of concept or an attack tool is available, so your teams have to process this alert. An attacker with a technician ability can exploit this threat note.

Solutions for this threat 

tcpdump: patch for print_prefix.
A patch is indicated in information sources.

AIX: patch for tcpdump.
A patch is indicated in information sources.

Fedora: new tcpdump packages.
New packages are available:
  Fedora 29: tcpdump 4.9.3-1.fc29
  Fedora 30: tcpdump 4.9.3-1.fc30
  Fedora 31: tcpdump 4.9.3-1.fc31

McAfee Web Gateway: version 7.8.2.16.
The version 7.8.2.16 is fixed:
  https://www.mcafee.com/enterprise/en-us/downloads/my-products.html

openSUSE Leap 15.0: new tcpdump packages.
New packages are available:
  openSUSE Leap 15.0: tcpdump 4.9.2-lp150.2.3.1

openSUSE Leap 15: new tcpdump packages (21/08/2019).
New packages are available:
  openSUSE Leap 15.0: tcpdump 4.9.2-lp150.7.1
  openSUSE Leap 15.1: tcpdump 4.9.2-lp151.4.3.1

openSUSE Leap 15: new tcpdump packages (21/10/2019).
New packages are available:
  openSUSE Leap 15.0: tcpdump 4.9.2-lp150.10.1
  openSUSE Leap 15.1: tcpdump 4.9.2-lp151.4.6.1

openSUSE Leap 42.3: new tcpdump packages.
New packages are available:
  openSUSE Leap 42.3: tcpdump 4.9.2-12.1

Oracle Solaris: patch for third party software of July 2019 v3.
A patch is available:
  https://support.oracle.com/rs?type=doc&id=1448883.1

RHEL 7, 8: new tcpdump packages.
New packages are available:
  RHEL 7.7: tcpdump 4.9.2-4.el7_7.1
  RHEL 8.0-8.1: tcpdump 4.9.2-6.el8

SUSE LE 12 SP3/4: new tcpdump packages.
New packages are available:
  SUSE LE 12 SP3: tcpdump 4.9.2-14.8.1
  SUSE LE 12 SP4: tcpdump 4.9.2-14.8.1

SUSE LE 12 SP4: new tcpdump packages.
New packages are available:
  SUSE LE 12 SP4: tcpdump 4.9.2-14.11.1

SUSE LE 15: new tcpdump packages (08/08/2019).
New packages are available:
  SUSE LE 15 RTM: tcpdump 4.9.2-3.6.1
  SUSE LE 15 SP1: tcpdump 4.9.2-3.6.1

SUSE LE 15: new tcpdump packages (16/10/2019).
New packages are available:
  SUSE LE 15 RTM: tcpdump 4.9.2-3.9.1
  SUSE LE 15 SP1: tcpdump 4.9.2-3.9.1

SUSE LE 15: new tcpdump packages (17/12/2018).
New packages are available:
  SUSE LE 15 RTM: tcpdump 4.9.2-3.3.1

Ubuntu: new tcpdump packages.
New packages are available:
  Ubuntu 18.04 LTS: tcpdump 4.9.3-0ubuntu0.18.04.1
  Ubuntu 16.04 LTS: tcpdump 4.9.3-0ubuntu0.16.04.1
  Ubuntu 14.04 ESM: tcpdump 4.9.3-0ubuntu0.14.04.1+esm1
  Ubuntu 12.04 ESM: tcpdump 4.9.3-0ubuntu0.12.04.1

Wind River Linux: version 10.17.41.19.
The version 10.17.41.19 is fixed.
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides a system vulnerability note. Each administrator can customize the list of products for which he wants to receive vulnerability alerts.