The Vigil@nce team watches public vulnerabilities impacting your computers, and then offers security solutions, a vigilance database and tools to fix them.

Vulnerability of wpasupplicant: five vulnerabilities

Synthesis of the vulnerability 

An attacker can use several vulnerabilities of wpasupplicant.
Vulnerable systems: Debian, openSUSE Leap, SLES.
Severity of this threat: 1/4.
Number of vulnerabilities in this bulletin: 5.
Creation date: 12/11/2015.
Références of this weakness: CVE-2015-4141, CVE-2015-4143, CVE-2015-4144, CVE-2015-4145, CVE-2015-4146, DSA-3397-1, openSUSE-SU-2016:2357-1, openSUSE-SU-2017:2896-1, openSUSE-SU-2020:2053-1, openSUSE-SU-2020:2059-1, SUSE-SU-2020:3380-1, VIGILANCE-VUL-18290.

Description of the vulnerability 

Several vulnerabilities were announced in wpasupplicant.

An attacker can trigger a fatal error in WPS UPnP, in order to trigger a denial of service. [severity:1/4; CVE-2015-4141]

An attacker can trigger a fatal error in EAP-pwd, in order to trigger a denial of service. [severity:1/4; CVE-2015-4143]

An attacker can trigger a fatal error in EAP-pwd, in order to trigger a denial of service. [severity:1/4; CVE-2015-4144]

An attacker can trigger a fatal error in EAP-pwd, in order to trigger a denial of service. [severity:1/4; CVE-2015-4145]

An attacker can trigger a fatal error in EAP-pwd, in order to trigger a denial of service. [severity:1/4; CVE-2015-4146]
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

This security threat impacts software or systems such as Debian, openSUSE Leap, SLES.

Our Vigil@nce team determined that the severity of this computer weakness note is low.

The trust level is of type confirmed by the editor, with an origin of LAN.

This bulletin is about 5 vulnerabilities.

An attacker with a expert ability can exploit this computer threat alert.

Solutions for this threat 

Debian: new wpa packages.
New packages are available:
  Debian 7: wpa 1.0-3+deb7u3
  Debian 8: wpa 2.3-1+deb8u3

openSUSE Leap 15.1: new wpa_supplicant packages.
New packages are available:
  openSUSE Leap 15.1: wpa_supplicant 2.9-lp151.5.10.1

openSUSE Leap 15.2: new wpa_supplicant packages.
New packages are available:
  openSUSE Leap 15.2: wpa_supplicant 2.9-lp152.8.3.1

openSUSE Leap 42.1: new wpa_supplicant packages.
New packages are available:
  openSUSE Leap 42.1: wpa_supplicant 2.2-8.1

openSUSE Leap: new hostapd packages.
New packages are available:
  openSUSE Leap 42.2: hostapd 2.6-5.3.1
  openSUSE Leap 42.3: hostapd 2.6-8.1

SUSE LE 15 RTM-SP2: new wpa_supplicant packages.
New packages are available:
  SUSE LE 15 RTM: wpa_supplicant 2.9-4.20.1
  SUSE LE 15 SP1: wpa_supplicant 2.9-4.20.1
  SUSE LE 15 SP2: wpa_supplicant 2.9-4.20.1
Full bulletin, software filtering, emails, fixes, ... (Request your free trial)

Computer vulnerabilities tracking service 

Vigil@nce provides software vulnerability announces. The technology watch team tracks security threats targeting the computer system.